RSPeer 1.53

Hi, RSPeer 1.53 has been released. Below is the changelog for this build

  • Improvements made to the debugger

  • Fixed several issues with Item for older style components such as the MTA shop (Thanks Gengsta)

  • RSPeer now sets a default Locale (Thanks Burak)

  • Fixed & improved Item.from

  • Fixed Minigames.teleport

  • Most EventListeners have been moved onto another thread

Sweeet, what about the Lumbridge Pub walking issue? No mention of it here, but I think it might have been fixed.

Thanks Burak

@Asta https://i.imgur.com/1bbmvjc.gifv Is this what you are referring to?

@MadDev i believe yeah thats the one happened to most of us

Thanks Spencer, very cool.

No ice

Where do I look for the new rspeer?

@gordo652 Running the launcher will automatically download it for you

@MadDev said in RSPeer 1.53:

@Asta https://i.imgur.com/1bbmvjc.gifv Is this what you are referring to?

Oof yes! This was so annoying xD.

@shiva99 This is not fixed.

@franny said in RSPeer 1.53:

@shiva99 This is not fixed.

Yea i know, i thought it was fixed. I got a little too excited there.

How do I update my client?

@biddyo

@Spencer said in RSPeer 1.53:

@gordo652 Running the launcher will automatically download it for you

@Spencer Ok I did that and it still gives me the error that the client is not updated.

“Incompatible ModScript. Please Update Bot” That’s what comes up when the client tries to load RS

@biddyo Make sure you’re running the launcher and not the bot directly