Null pointer error on client start

Issue: Client will not start due to null pointer error
Steps to recreate: Launch the client (via Jar or launcher)
Java Version: Adopt OpenJDK 11
Operating System (Windows 10, Mac OS X, Linux, etc): Win10
Are you using a proxy (Yes / No): No
Error message (If applicable): Failed to load runescape. java.lang.NullPointerError

I have tried deleting the .rspeer folder and the cache folder to no avail. I have tried re-downloading the launcher, deleting all rspeer related folder and still getting this error.

Last console messsage is Injector - Injecting library.

Launching the .jar file from the command line shows this error message -

java.lang.NullPointerException
    at org.rspeer.21.11.50.41.iiIIIiiiIiiiI(zt:175)
    at org.rspeer.21.11.90.iiIIIiiiIiiiI(rt:136)
    at org.rspeer.21.41.iiIIIiiiIiiiI(yr:543)
    at org.rspeer.21.41.IIiIIiiiiIIiI(yr:392)
    at org.rspeer.21.41.iiiiIiiiIIiii(yr:123)
    at org.rspeer.Bootstrap.injectAndLoad(ir:31)
    at org.rspeer.11.90.iIiIiiiiIIIiI(zl:37)
    at org.rspeer.11.90.iiIIIiiiIiiiI(zl:196)
    at org.rspeer.11.21.70.iiiiIiiiIIiii(pj:169)
    at org.rspeer.11.21.70.iiIIIiiiIiiiI(pj:116)
    at org.rspeer.11.90.iiiiIiiiIIiii(zl:25)
    at org.rspeer.Bootstrap.start(ir:28)
    at org.rspeer.Application.main(vz:162)

This does not cause the client to crash. Just fail to load runescape.

RSPeer was working fine before.

Client had been down to rs update. Try now.

Yup my launcher is downloading a 2.25 update now. Thank you very much :).

Happy days buddy.