link your account and launcher

Issue:i dont vunderstand how to do the linked thing there literally is no instructions and also my launchers say imout of date but i installed the newest one
Steps to recreate: i
Java Version:1.8.0_231
Operating System (Windows 10,
Are you using a proxy No):
Error message (If applicable): its says my version is out of date from v2.14