Issues with Proxy Services

Issue: When using proxy services, the proxies are accepted by client but rejected by Jagex.
Steps to recreate: Using Blazing SEO, logged 5 proxies into “Manage Proxies” (All IPv4 SOCK5 Port 1080, but from different areas) and then assign them in Quick Launch. Everything works fine, the RSPeer client okays them, but Jagex rejects login.
Java Version: 11
Operating System (Windows 10, Mac OS X, Linux, etc): Windows 10
Are you using a proxy (Yes / No): Trying
Error message (If applicable):

Is it the service I’m going with, or something I’m doing wrong? Is there a reliable proxy service that you recommend? Does Jagex have the ability to mass reject clients of particular proxy services? Sorry for the dumb questions, thanks!

Did you test them through a browser? Make sure you have whitelisted your home IP through Blazing’s dashboard.

Thanks for the suggestion, I had already done that earlier though. I whitelisted my IP first, following Blazing’s site guide. I waited the half hour for the countdown timer, and all assigned proxies work except logging into Runescape. Trying to log in outside of RSPeer client through the Jagex website didn’t work, either. Maybe a bad batch? I only got to select country, so all 5 proxies I was assigned were from the same city - though I don’t think that would make any difference. OSRS only accepts IPv4 SOCK5, right? And the port will always be 1080? Thanks again, have you gotten Blazing to work?

So through a browser you are able to get to google etc. but not able to login through the runescape website? What is the message it gives you? I used them a while back and they worked fine.

im not trying to hijack this thread, i feel we both have the same issue and can help faster. So I’m having the same issue and can’t check the browser considering it doesn’t ask for a username and password. I assume we have the same problem here but I’m using a vpn’s server as proxy and using the email as the user which is the only thing that would be different but shouldn’t matter right?

Tried on the firefox browser. @Harpax try to enable this Do not prompt for authentication if password is saved .

then it’ll ask you for a username and password. For me it didn’t work so its a proxy issue on my end. Hope everything works out fine for you and let us know how you solved it

Do you mean through Blazing’s site or on the RSPeer client? I think you’re right about the username password thing, Blazing doesn’t give me one because it uses my static IP but maybe I need to put my account info into the RSPeer proxy thing. I’ll try it again post results, thank you!

I mean through your browsers proxy settings. Go to browser options and search proxy. I’ve bought proxies a few times and those times they supplied a username and password along with the ip:port. Actually just remembering they give you 2 options, one to limit to ips posted and other one is to enable username and password. rspeer user and pass should be optional so maybe it doesn’t matter and is a proxy issue? idk but I’m having a proxy issue on my end and not rspeer atm

I just found the setting through Mozilla, that’s what I did before on my browser. At first it wouldn’t let me connect to anything - I fiddled with it and it let me load other sites, thought all was well, went through RSPeer just fine but wouldn’t log me into Runescape. Even on browser, it loads the webclient but doesn’t accept my login. I got the proxies I was originally assigned reset though, so in 20 minutes or so I can try again and see if it budges. Hope you make progress on your side! Do you have it set to authorize via IP or login?

Not sure but another thing is that proxy sellers have told me what I’m going to be using the proxy for, what apps or websites I’ll be visiting. I assume they block anything but that website. Mention to blaze its for and

idk much honestly, I’m new to this still so maybe just wasting your time here lol

I checked their site, the only thing reported to be blocked is Nike, TicketMaster, and PokemonGO. I think I messed up earlier though, rather than use my e-mail login I set the proxy site to give me a random username and password and that changed the port from 1080 to 4444 so it wouldn’t have been able to connect. I switched it back to port 1080 and IP authentication, and now I’m trying my e-mail for the proxy login in RSPeer. Maybe I’m just going in circles but I don’t want to have missed something obvious - no dice yet, but I feel like it’s on my end and their service will work. You’re not wasting my time at all - you’re helping me check over things I passed over before. Thanks!

I fixed my issue with the browser. I used p2p proxy server and port 80 for the browser. Haven’t tried 1080 which I think I should for osrs. Wish me luck

what if its rspeer server issue? I keep getting connection failure in bot management.**image **

Worked for me, client loaded everything works fine. I hope you fix your issue soon

Glad to hear you worked it out! Mine is semi-worked out, turns out the proxy I was testing on is the only one out of those 5 that refuses to connect - the other 3 work without issue and the 4th is iffy but sometimes works. I guess my next step is to request Blazing to issue me another, but that’s on my end. Thanks for your help!